Mantiz Saturn Pro broke my Laptop's Thunderbolt (and charging) port
 
Notifications
Clear all

Mantiz Saturn Pro broke my Laptop's Thunderbolt (and charging) port  

  RSS

Henning Pohl
(@henning_pohl)
Active Member
Joined: 3 weeks ago
 

2 weeks ago I purchased a Mantiz Saturn Pro V2 and it has been working fine since then.

So I decided to get a new ThinkPad with TB4 and a new screen to go along with it. I have been using them together for 2 days and things have been going smoothly.

This morning like any other I turned on the power and my circuit breaker (230V, 13A) flipped instantly. After switching it back on I realized my eGPU and the USB Hub within was not working anymore. My laptop was not charging either. I tried turning it off and on again, plugging everything in and out - no results. The eGPU's PSU must have died then, right? Okay, fine, I'll ask Mantiz support for help. After doing so I plugged the USB-C charger that came with the Laptop in and noticed it was barely or not charging at all. There also was a very noticeable coil whine, way more than before. So I plugged in my phone to see if that connects or charges - NOPE. My iPad - NOPE.

Next I plugged in the eGPU in my other laptop (after turning on power) and everything including the GPU inside is working (phew).

So having the eGPU destroy itself is one thing, but killing your other devices - not cool.

I am pissed. Any advice what to do next?

To do: Create my signature with system and expected eGPU configuration information to give context to my posts. I have no builds.

.

ReplyQuote
Henning Pohl
(@henning_pohl)
Active Member
Joined: 3 weeks ago
 

So the next day my Laptop's TB port started working again out of the blue. I'm still really scared.

To do: Create my signature with system and expected eGPU configuration information to give context to my posts. I have no builds.

.

ReplyQuote