[MBP 2019 13" + Razer Core X Chroma + RX 570 + MacOS 10.15.6] Help on random fre...
 
Notifications
Clear all

[MBP 2019 13" + Razer Core X Chroma + RX 570 + MacOS 10.15.6] Help on random freezes  

  RSS

hozjt
(@hozjt)
New Member
Joined: 3 months ago
 

Hi all

Trying hard to solve random freezes on newly bought configuration as follows:

Symptoms:

  • Everything worked great the 1st/2nd days, for prolonged session of work + light gaming
  • Then starting from the 3rd day (today is the 5th day), random freezes would occur regardless of what I was doing: be it web browsing or gaming
  • Strange enough, when it "freezes", the external display would show a grey-ish or pink-ish color but the internal display continues to display correctly, and after unplugging the eGPU, 1 out of a few times the system would recover after a few seconds without completely crash the MBP
  • The freezing typically happen soon after a restart, but tend to occur less after longer session (30 mins or so)
  • I have done nothing different after the 1st/2nd day to the system

Other issues I am seeing with the configuration above (not sure if known issues)

  • HDMI port does not work... only DP
  • USB port on the Core X Chroma not working for external HDD

 

Would really like to hear your thoughts. 

Thanks in advance for your help.

This topic was modified 3 months ago

To do: Create my signature with system and expected eGPU configuration information to give context to my posts. I have no builds.

.

ReplyQuote
itsage
(@itsage)
Illustrious Member Admin
Joined: 4 years ago
 

@hozjt, What shape is the MSI Radeon RX 570 ARMOR 8G? If the HDMI port does not work there's likely a firmware and/or hardware issue with the GPU.

 

external graphics card builds
best laptops for external GPU
eGPU enclosure buyer's guide

 
2020 15" HP Spectre X360 [11th,4C,G] + RTX 2080 Ti @ 32Gbps-TB4 (AORUS Gaming Box) + Win10 2004 [build link]  


ReplyQuote
hozjt
(@hozjt)
New Member
Joined: 3 months ago
 

@itsage, thank you for your reply. I have returned the GPU and ordered a new, hopefully it will work better...

 

To do: Create my signature with system and expected eGPU configuration information to give context to my posts. I have no builds.

.

ReplyQuote
hozjt
(@hozjt)
New Member
Joined: 3 months ago
 

 @itsage, I have been testing with the new card, the freezing issues are completely gone so indeed it was a hardware issue with the old card. Thanks again for your advise!

 

To do: Create my signature with system and expected eGPU configuration information to give context to my posts. I have no builds.

.

itsage liked
ReplyQuote