My eGPU switches off suddenly. Please help
 
Notifications
Clear all

My eGPU switches off suddenly. Please help  

  RSS

Ironman Pablo
(@ironman_pablo)
Active Member
Joined: 2 years ago
 

Hello All

this is my first post. Thanks to the community for all the help and knowledge you provide.

I own an iMac Pro 3GHz 10 Core Intel Xeon W, with 64 GB of RAM and a Radeon Pro Vega 64 16GB. I am on Catalina 10.15.7.

I also own a Sonnet eGFX Breakaway BOX with AMD Radeon Pro WX9100

I have connected 1 external 4K display to the sonnet, nothing else.

Running some programs like Adobe Premiere, mimoLive or Wirecast (streaming software), my external sonnet box switches off suddenly. It starts with the external monitor connected to it, and then is a chain reaction till all my software collapses.

I changed the power source of the eGPU for a Corsair 850 platinum, the ventilator, the thunderbolt 3 cable for a premium one...nothing, it keeps happening. 

What can it be? What can I do?

I do have a crash report but I do not know how to upload it. 

Thanks for your help

iMac Pro 2017 running Radeon Pro Vega 56 8 GB & 32 GB 2666 MHz DDR4


ReplyQuote
itsage
(@itsage)
Founder Admin
Joined: 5 years ago
 

@ironman_pablo, If the enclosure itself shuts off, I would guess it's a power issue. 850W should be more than enough for the WX 9100. Reading closely to the symptoms it seems the software are crashing rather than due to eGPU experiencing issue rather than power loss. Did you buy this graphics card new?

 

LinkedIn | Twitter | Facebook | Youtube | Instagram
 
external graphics card builds
best laptops for external GPU
eGPU enclosure buyer's guide

 
2021 13" ASUS ROG Flow X13 (RTX3050Ti) [R5K,8C,H] + RTX 3080 @ 64Gbps-XG (XG Mobile) + Win10 20H2 [build link]  


ReplyQuote
Ironman Pablo
(@ironman_pablo)
Active Member
Joined: 2 years ago
 

@itsage, I bought it new. 

Do you suspect it could be a faulty graphic card?

Thanks

 

iMac Pro 2017 running Radeon Pro Vega 56 8 GB & 32 GB 2666 MHz DDR4


ReplyQuote
itsage
(@itsage)
Founder Admin
Joined: 5 years ago
 

@ironman_pablo, I'm not sure it's the GPU if you bought it new. My WX 9100 has been running for almost 2 years and there's no hiccup. Which PSU did your Sonnet Breakaway Box originally come with?

 

LinkedIn | Twitter | Facebook | Youtube | Instagram
 
external graphics card builds
best laptops for external GPU
eGPU enclosure buyer's guide

 
2021 13" ASUS ROG Flow X13 (RTX3050Ti) [R5K,8C,H] + RTX 3080 @ 64Gbps-XG (XG Mobile) + Win10 20H2 [build link]  


ReplyQuote
Ironman Pablo
(@ironman_pablo)
Active Member
Joined: 2 years ago
 

@itsage, It came with the Power Source 

http://www.highpower-tech.com/OEM/products_main.php?class=20200525115155&id=20200602114127

High Power HP1-J650GD-F12S

I am running nuts, thinking or returning the Sonnet, the graphic card...the computer..

 

Thanks for your help

 

 

iMac Pro 2017 running Radeon Pro Vega 56 8 GB & 32 GB 2666 MHz DDR4


ReplyQuote
itsage
(@itsage)
Founder Admin
Joined: 5 years ago
 

@ironman_pablo, 650W version of the Sonnet Breakaway Box should be able to handle the WX 9100. I would contact the retailer for an exchange.

 

LinkedIn | Twitter | Facebook | Youtube | Instagram
 
external graphics card builds
best laptops for external GPU
eGPU enclosure buyer's guide

 
2021 13" ASUS ROG Flow X13 (RTX3050Ti) [R5K,8C,H] + RTX 3080 @ 64Gbps-XG (XG Mobile) + Win10 20H2 [build link]  


ReplyQuote
Ironman Pablo
(@ironman_pablo)
Active Member
Joined: 2 years ago
 

Hello all

I am going nuts. These are all actions I took:

- Exchanged the AMD card with the supplier, they sent a new one

- Exchanged the closure for a new one (Razer Core X)

- Exchanged the Thunderbolt 3 for the best one I could find....

 

Same result. Please see a video (note that I used the video I filmed with the old enclosure), but issue is exactly the same. 

It doesn't allow me to embed mp4 file, but here is the link: https://app.box.com/s/848iyb1qcp58mfw2fj6wt1n7mg3o4nqf

I believe that for some reason, the graphic card gets hot and its protection system starts, then the external monitor shuts off and then my Mac. 

this has happened during streaming sessions with more than 4.000 viewers online...not ideal.

Thanks for your help!!!!

iMac Pro 2017 running Radeon Pro Vega 56 8 GB & 32 GB 2666 MHz DDR4


ReplyQuote
Ironman Pablo
(@ironman_pablo)
Active Member
Joined: 2 years ago
 
Guys, 
Anyone can help?
 
Posted by: @ironman_pablo

Hello all

I am going nuts. These are all actions I took:

- Exchanged the AMD card with the supplier, they sent a new one

- Exchanged the closure for a new one (Razer Core X)

- Exchanged the Thunderbolt 3 for the best one I could find....

 

Same result. Please see a video (note that I used the video I filmed with the old enclosure), but issue is exactly the same. 

It doesn't allow me to embed mp4 file, but here is the link: https://app.box.com/s/848iyb1qcp58mfw2fj6wt1n7mg3o4nqf

I believe that for some reason, the graphic card gets hot and its protection system starts, then the external monitor shuts off and then my Mac. 

this has happened during streaming sessions with more than 4.000 viewers online...not ideal.

Thanks for your help!!!!

 

iMac Pro 2017 running Radeon Pro Vega 56 8 GB & 32 GB 2666 MHz DDR4


ReplyQuote