My Gigabyte Aorus Gaming Box has stopped turning on
 
Notifications
Clear all

My Gigabyte Aorus Gaming Box has stopped turning on  

  RSS

Shitiz Garg
(@shitiz_garg)
Active Member
Joined: 2 years ago
 

Okay so I have had this box for a few months now and suddenly it has stopped working. It has a GTX1070 in it and I haven't performed any firmware upgrades. When I connect it to macOS, it is recognized as a Thunderbolt enclosure. When I connect it to Windows, I get the "This USB device is not recognized" notification and the Gaming Box itself does not light up. I tried resetting it by disconnecting its power cable (I left it alone for almost 9 hours) and it did not make a difference. My Laptop is charging and the USB ports at the back of the enclosure seem to be working.

Could it be a PSU issue or is my GPU itself blown up? Is there a way I can diagnose or attempt to fix this? I would appreciate any help. My host is a MacBook Pro with Touch Bar (2017 model). I haven't had any software changes. 

This topic was modified 11 months ago

To do: Create my signature with system and expected eGPU configuration information to give context to my posts. I have no builds.

.

ReplyQuote
Topic Tags
Arzen
(@arzen)
Eminent Member
Joined: 2 years ago
 

I am having the same issue with my rx580 gaming box from Gigabyte.

I just reinstalled my MacOS but it still doesn't recognize the eGPU when I plug it in. It shows the GAMING BOX in the System Report and it can use the USB ethernet that is plugged in... this is a super mystery to me!

MacBook Pro 16" - 2.3 i9, 16GB, 1TB, 5500 w/ 4GB; Gigabyte RX 580 Gaming Box


ReplyQuote