[Need Help] Zotac AMP Box + XFX RX560 + MBP 2017 + 10.15.6 black screen
 
Notifications
Clear all

[Need Help] Zotac AMP Box + XFX RX560 + MBP 2017 + 10.15.6 black screen  

  RSS

Naeem Noor
(@naeem_noor)
Active Member
Joined: 1 year ago
 

Hi All,
I have the following setup

  • Zotac AMP Box (not mini)
  • XFX RX560
  • 13inch non-touchbar MBP 2017 
  • Catalina 10.15.6 

I get a black screen as I plug it in and it restarts + and goes on a loop.

Any help would be appreciated.

Thanks in advance.

2017 MBP 13' + AMP BOX + XFX RX560 (Sapphire BIOS)


ReplyQuote
itsage
(@itsage)
Founder Admin
Joined: 5 years ago
 

@naeem_noor, It's likely an issue with the XFX GPU firmware. If possible, flash the vBIOS with one from Sapphire or one with matching VRAM manufacturer.

 

LinkedIn | Twitter | Facebook | Youtube | Instagram
 
external graphics card builds
best laptops for external GPU
eGPU enclosure buyer's guide

 
2021 13" ASUS ROG Flow X13 (RTX3050Ti) [R5K,8C,H] + RTX 3080 @ 64Gbps-XG (XG Mobile) + Win10 20H2 [build link]  


ReplyQuote
Naeem Noor
(@naeem_noor)
Active Member
Joined: 1 year ago
 

@itsage, Thank you for your reply.

How can I flash it with the enclosure? I do not have a PC.

I tried it with Bootcamp, but Im stuck with the code 12.

Btw I bought it to use with macOS.

Thanks in advance.

 

2017 MBP 13' + AMP BOX + XFX RX560 (Sapphire BIOS)


ReplyQuote
itsage
(@itsage)
Founder Admin
Joined: 5 years ago
 

@naeem_noor, You can try it in Windows Boot Camp. I don't think error 12 prevents ATIFlash from working.

 

LinkedIn | Twitter | Facebook | Youtube | Instagram
 
external graphics card builds
best laptops for external GPU
eGPU enclosure buyer's guide

 
2021 13" ASUS ROG Flow X13 (RTX3050Ti) [R5K,8C,H] + RTX 3080 @ 64Gbps-XG (XG Mobile) + Win10 20H2 [build link]  


ReplyQuote
Naeem Noor
(@naeem_noor)
Active Member
Joined: 1 year ago
 

Hi @itsage,

I'm getting an error while flashing 'subsystem id mismatch'. I tried to flash this sapphire bios. Here is a screenshot of my GPUZ and SRBPolaris.

Thanks in advance.

2017 MBP 13' + AMP BOX + XFX RX560 (Sapphire BIOS)


ReplyQuote
itsage
(@itsage)
Founder Admin
Joined: 5 years ago
 

@naeem_noor, Keep looking for one that may match the memory brand on your XFX card.

 

LinkedIn | Twitter | Facebook | Youtube | Instagram
 
external graphics card builds
best laptops for external GPU
eGPU enclosure buyer's guide

 
2021 13" ASUS ROG Flow X13 (RTX3050Ti) [R5K,8C,H] + RTX 3080 @ 64Gbps-XG (XG Mobile) + Win10 20H2 [build link]  


ReplyQuote
Naeem Noor
(@naeem_noor)
Active Member
Joined: 1 year ago
 

UPDATE: I managed to find a Sapphire RX560 with Hynix memory BIOS and I flashed it! It works perfectly so far, plug and play.

rx560
rx5602
This post was modified 1 year ago

2017 MBP 13' + AMP BOX + XFX RX560 (Sapphire BIOS)


itsage liked
ReplyQuote
cmd8086
(@cmd8086)
Active Member
Joined: 11 months ago
 

@naeem_noor, that's exactly what I addressed in my post: If you have a XFX RX 560 4GB you Must see this

 

Macbook Pro 15" Late 2013 - Intel i7-4850HQ @ 2.3GHz - nVidia GeForce GT 750M 2GB VRAM - 16GB RAM DDR3 @ 1600MHz - Custom eGPU enclosure with JHL7440 chipset - XFX RX 560 4GB VRAM @ Sapphire VBIOS


ReplyQuote