New Dell XPS 15 working weird with 2060 Super
 
Notifications
Clear all

New Dell XPS 15 working weird with 2060 Super  

  RSS

Masgimor
(@masgimor)
New Member
Joined: 5 months ago
 

So I am currently using the newest version of the Dell XPS 15. When I plug it into the Razer Core X, with a 2060 Super it does one of two things, work or blue screen my computer. Recently more of the later. The computer seems to recognize the Egpu as the windows connected sound plays right before the blue screen. Additionally if it does work, unless I am playing a game, it will freeze and crash, or my external mouse will stop working. Any help

 

addtional info.

a very similar thing happened with same graphics card and enclosure with my boot amp MacBook Pro before I got the XPS.

 

the Radeon graphics card I have works better and doesn’t blue screen at all, however it does make the screen flicker in graphically challenging games.

 

whenever I plug in the enclosure it tries to charge the laptop, however it doesn’t have the same power so it warns of a slow charger

 

i don’t know what else will help, but thank you for the help.

To do: Create my signature with system and expected eGPU configuration information to give context to my posts. I have no builds.

.

ReplyQuote
itsage
(@itsage)
Illustrious Member Admin
Joined: 4 years ago
 

@masgimor, If your XPS 15 has an Nvidia dGPU, run DDU to remove graphics drivers first. You can then manually install the latest drivers for the eGPU which should work with the dGPU.

 

external graphics card builds
best laptops for external GPU
eGPU enclosure buyer's guide

 
2020 15" HP Spectre X360 [11th,4C,G] + RTX 2080 Ti @ 32Gbps-TB4 (AORUS Gaming Box) + Win10 2004 [build link]  


ReplyQuote
Masgimor
(@masgimor)
New Member
Joined: 5 months ago
 

@itsage, thanks for the help! I’ve uninstalled the drivers with DDU. How do I manually install the drivers for the egpu. Is it the most recent nvidia drivers? Sorry for my inexperience.

 

To do: Create my signature with system and expected eGPU configuration information to give context to my posts. I have no builds.

.

ReplyQuote