*update - fixed* new Mantiz Venus won't power up at all
 
Notifications
Clear all

[Solved] *update - fixed* new Mantiz Venus won't power up at all  

  RSS

Don Lee
(@don_lee)
New Member
Joined: 5 months ago
 

*Update*

With the quarantine not being able to get any parts but have essentially infinite time I disassembled everything to look for any problems. Disconnected from everything I was able to get the PSU fan to spin up by shorting pin 15 and 16 on the 24 pin ATX connector. Didn't see any shorts or burnouts on any of the boards. Cleaned every connector and reassembled everything in the bare enclosure (no sata drive and no gpu). Was able to get just the PSU to power my 2017 macbook pro. Installed just the sata drive but it wasn't recognized. The one spare part I had was a sata cable, lo and behold the one I initially used was faulty and now the drive was working. Just installed the RX5700 and osx is seeing it.

Still not sure what the original problem was but taking it apart and putting it back together did the trick.

Next up bootcamp and windows.

I thank the this forum and all the folks on it, it's been an inspiration researching what others have been doing and I'm excited to be joining in on the fun now!

***

 

Hi, I got a new Mantiz Venus directly from them and have finally assembled it with a RX5700 and SDD. When I tried turning it on nothing happened. Tried Disassembling everything and just powering the PSU and still no dice. Guessing that the PSU is bad.

I contacted Mantiz a couple of days ago for what else I should be doing to diagnose and fix this issue but I haven't heard back. 

Is a faulty PSU a common issue with the Mantiz? What's the response time generally when emailing [email protected]mymantiz.com and are they good about replacing new parts that were DOA?

If I shouldn't expect help from Mantiz it looks like folks are upgrading to the Corsair SF600 600 Watt 80+ Gold. Is that my best option?

Thanks!

This topic was modified 5 months ago

2020 13" MacBook Pro (10th,4C,G) + Mantiz Venus + PowerColor RX 5700 XT + Win10 1903 v1 (18362.30) / OSX 10.15.4


ReplyQuote
jangoloti
(@jangoloti_1)
Estimable Member
Joined: 11 months ago
 

My Sonnet 550 was doing the same thing, it was the cable that did not allow the card to be recognized by the OS. The TB3 adapter was recognized though.

Check before blaming the PSU, you might be surprised.

This post was modified 5 months ago

Mac Mini 2018 i7 16 GB 512 GB SSD, Mac Book Pro 2016, HP Z31x, Sonnet Breakaway Box 550 W, Nitro+ RX5700 XT, KFA2 SNPR 1060 6GB eGPU,...


Don Lee liked
ReplyQuote