Razer Core + RX5700XT not working anymore
 
Notifications
Clear all

Razer Core + RX5700XT not working anymore  

  RSS

Christian Prinoth
(@christian_prinoth)
Active Member
Joined: 12 months ago
 

I have a Razer Core X with an XFX RX5700 XT inside, connected to a 2018 Mac Mini. This has worked fine for many months now both in MacOS and Bootcamp (no hotplug).

Suddenly, everything has stopped working.

In MacOS, if I plug in the eGPU, the OS freezes and then reboots after a few seconds. It will not boot up with the eGPU connected and turned on.

In Bootcamp, when hot-plugging I get error 12 as before, and if I cold-plug it, then I will just get to the green flashing screens, but no output is shown when I switch my monitor's input to the cable connected to the eGPU's output.

I do not think I have done any OS upgrades both in Win and MacOS, so not sure what is going wrong here. I also tried connecting the eGPU to a MacBook Pro, and it freezes in the same way as the Mac Mini. So maybe a hardware issue with the eGPU?

Does anyone have suggestions about how I may debug these issues? Unfortunately I do not have a PC handy where I might try the GPU by itself.

Thanks,

CP

2018 Mac Mini [8th,6C,B] + RX 580 @ 32Gbps-TB3 (Razer Core X) + macOS 10.15.4 & Win10 1903 // Oculus Quest [build link]  

ReplyQuote
itsage
(@itsage)
Founder Admin
Joined: 4 years ago
 

@christian_prinoth, What is the version of Windows 10? Run "winver" to see.

 

LinkedIn | Twitter | Facebook | Youtube | Instagram
 
external graphics card builds
best laptops for external GPU
eGPU enclosure buyer's guide

 
2020 13" MacBook Pro [10th,4C,G] + RX 6700 XT @ 32Gbps-TB3 (CM MasterCase EG200) + Win10 1903 [build link]  


ReplyQuote
Christian Prinoth
(@christian_prinoth)
Active Member
Joined: 12 months ago
 

I am on 19042.867

 

As I mentioned, this exact same setup has been working until a few days ago. Now it won't work in windows/bootcamp, but even worse it will also crash macos and prevent booting up when egpu is connected and turned on. In the past, even before I got it working in bootcamp reliably, it never had issues in macos. Which is why I fear that something is wrong hardware-wise...

2018 Mac Mini [8th,6C,B] + RX 580 @ 32Gbps-TB3 (Razer Core X) + macOS 10.15.4 & Win10 1903 // Oculus Quest [build link]  

ReplyQuote