Razer Core X Chroma - Can anyone confirm if the PSU fan is always on?
 
Notifications
Clear all

Razer Core X Chroma - Can anyone confirm if the PSU fan is always on?  

 of  2
  RSS

craftsman
(@craftsman)
Estimable Member
Joined: 2 years ago
 

@tonyvee thanks for DMing me more info and tests on your eGPU set up. It's good that users share their experiences so we can help others.

After two weeks of testing and studying many user posts, I have noticed that some Radeon RX Vega with Revision ID 0x00c0 have stability problems and video bugs. If you bought a used card that was firmware modded or used for mining then that would exacerbate the problem.

RX Vega with Revision ID 0x00c1 have a much better experience. Therefore I have refunded my Vega 64 with Revision 0x00c0.

I'll now purchase the Radeon VII but will first wait for the fan fix and for Apple to list it in their support article.

 

2019 16" MacBook Pro (RP5500M) [9th,8C,H] + RX 5700 XT @ 32Gbps-TB3 (Razer Core X Chroma) + macOS 10.15.1 [build link]  

ReplyQuote
TonyVee
(@tonyvee)
Active Member
Joined: 2 years ago
 

@craftsman thanks for the info and helping us ID the faulty revision. I did a google and saw similar reports about that going back years on Windows and Mac

13 MacBook Pro 2017 Quad Core Razer Core X Radeon 56


ReplyQuote
zhoowa
(@zhoowa)
Active Member
Joined: 2 months ago
 

@rb6freak, i know it has been a while but i wonder if you managed to isolate the no spinning problem? got one right here on Chroma but don't get is it a faulty fan or something.

 

regards

 

Dell XPS 13 9380 + Razer Core X Chroma + EVGA RTX 2070 SUPER XC Ultra


ReplyQuote
rb6freak
(@rb6freak)
Eminent Member
Joined: 4 years ago
 

@zhoowa I believe it would spin up once it reached a certain temperature. Although I no longer own this Razer Core X Chroma, I switched back to my Akitio Node custom setup.

2020 17" Dell XPS 17 9700 (RTX2060) [10th,8C,H] + RTX 2080 Ti @ 32Gbps-TB3 (AKiTiO Node) + Win10 [build link]  

ReplyQuote
 of  2