razer core x constantly freezes/crashes lenovo c940
 
Notifications
Clear all

razer core x constantly freezes/crashes lenovo c940  

  RSS

Ben Paulaitis
(@ben_paulaitis)
New Member
Joined: 1 year ago
 

I just got a core x chroma + rtx 2070 and 9 times out of 10 it will crash my computer or freeze it. On the few times  it doesn't I can see the rtx 2070 in display drivers but it has an error 43. please help? 


 

To do: Create my signature with system and expected eGPU configuration information to give context to my posts. I have no builds.

.

ReplyQuote
MaxRD
(@maxrd)
Active Member
Joined: 1 year ago
 

I don't know if this helps, but I found out that RTX 20xx cards will crash and freeze the system randomly unless you set the Power Management Mode in the NVidia CP to Prefer Maximum Performance. The default Optimal Power caused my system (Razer Blade 13 1650) to randomly freeze when the Core X was connected. I replaced 2 brand new RTX 2060 Super, reinstalled Windows and drivers countless times trying to troubleshoot this. Interesting thing is that if I used my old GTX Titan it worked fine, that's why I originally thought it was a defective GPU . I saw other people reporting similar issues that have been resolved by simply changing this setting. I have been almost a month crash free.

 

Razer Blade 13 (GTX 1650), 2TB Samsung 970 Evo Plus, Razer Core X, Asus Strixx RTX 2060 Super


ReplyQuote
Lawless Heaven
(@lawless_heaven)
Active Member
Joined: 3 years ago
 

@maxrd, Whats your fps in games like COD warzone, BF ? Witcher ? Thinking about replacing my RX 5700 Xt with RTX 2070S

 

Asus G501VW I7 6700HQ Razer Core X RTX 2070 SUPER


ReplyQuote
elclay
(@elclay)
New Member
Joined: 11 months ago
 
Posted by: @maxrd

I don't know if this helps, but I found out that RTX 20xx cards will crash and freeze the system randomly unless you set the Power Management Mode in the NVidia CP to Prefer Maximum Performance. The default Optimal Power caused my system (Razer Blade 13 1650) to randomly freeze when the Core X was connected. I replaced 2 brand new RTX 2060 Super, reinstalled Windows and drivers countless times trying to troubleshoot this. Interesting thing is that if I used my old GTX Titan it worked fine, that's why I originally thought it was a defective GPU . I saw other people reporting similar issues that have been resolved by simply changing this setting. I have been almost a month crash free.

 

I have a Lenovo C940 + Razer X Core + GTX 2060 Super, and it presented the same problem, this was the definitive solution. Thanks for the info

To do: Create my signature with system and expected eGPU configuration information to give context to my posts. I have no builds.

.

ReplyQuote
MaxRD
(@maxrd)
Active Member
Joined: 1 year ago
 

@elclay, glad it worked for you as well. Remember to change the setting every time you update the Nvidia driver.

 

Razer Blade 13 (GTX 1650), 2TB Samsung 970 Evo Plus, Razer Core X, Asus Strixx RTX 2060 Super


ReplyQuote
MaxRD
(@maxrd)
Active Member
Joined: 1 year ago
 

@lawless_heaven, mine is a 2060S. I don't play any of those games sorry. In MW regular MP I get around 90-120fps at 1080p all maxed out. The 2070S is generally faster than the 5700XT across the board.

 

Razer Blade 13 (GTX 1650), 2TB Samsung 970 Evo Plus, Razer Core X, Asus Strixx RTX 2060 Super


ReplyQuote
Alastair Harlow
(@alastair_harlow)
New Member
Joined: 9 months ago
 

@maxrd, I love you. This worked and rescued my XPS 13, which I was starting to give up on. 

It worked fine for gaming but if doing anything else would cash randomly (usually within 5-10 minutes) and need to be hard reset (power button held down for 10 secs). Not usable. 

Definite issue with the software if this can happen on the defaults, but your suggestion fixed it completely. 

 

To do: Create my signature with system and expected eGPU configuration information to give context to my posts. I have no builds.

.

ReplyQuote
Jolan De Nef
(@jolan_de_nef)
New Member
Joined: 6 months ago
 
Posted by: @maxrd

I don't know if this helps, but I found out that RTX 20xx cards will crash and freeze the system randomly unless you set the Power Management Mode in the NVidia CP to Prefer Maximum Performance. The default Optimal Power caused my system (Razer Blade 13 1650) to randomly freeze when the Core X was connected. I replaced 2 brand new RTX 2060 Super, reinstalled Windows and drivers countless times trying to troubleshoot this. Interesting thing is that if I used my old GTX Titan it worked fine, that's why I originally thought it was a defective GPU . I saw other people reporting similar issues that have been resolved by simply changing this setting. I have been almost a month crash free.

 

I tried this today. Seems to work for me. Had this at least once a day until I tried this.

To do: Create my signature with system and expected eGPU configuration information to give context to my posts. I have no builds.

.

ReplyQuote
awf476
(@awf476)
New Member
Joined: 5 months ago
 

So here's my question. I would love to be able to try this solution as my computer completely freezes immediately after I plug in my Razer Core but the problem is that I cannot open the NVIDIA CP because it tells me that an NVIDIA graphic s card (that is inside of the eGPU) was not detected on my system. So I can't open up to app from the Microsoft Store to change the power settings? Nor can I install the graphics card drivers either for the same reason - any thoughts? Thank you in advance.

To do: Create my signature with system and expected eGPU configuration information to give context to my posts. I have no builds.

.

ReplyQuote
Andrej Kopták
(@andrej_koptak)
New Member
Joined: 3 months ago
 

@ben_paulaitis,

Hi,

I had the same problem. Lenovo T490+Razer Core X Chroma (RTX 2060 Super)+external monitor Lenovo Y25-25 (G-Sync Compatible)

Solved:

  1. [Please login to see this]

  2. NVIDIA Control Panel
  3. 3D settings - Manage 3D settings
  4. Global Settings - High-performance NVIDIA processor
  5. Power management mode - Prefer maximum performance (FPS increased)
  6. and also in the NVIDIA Control Panel - Display - Set up G-SYNC - turn off G-SYNC (It no longer freezes)

I guess Thunderbolt 3 doesn't support G-Sync yet.

I hope it will be helpfull.

Andrej


 

This post was modified 3 months ago

To do: Create my signature with system and expected eGPU configuration information to give context to my posts. I have no builds.

.

ReplyQuote