Throttled CPU performance when Thunderbolt 3 eGPU connected | Native Windows 10
 
Notifications
Clear all

Throttled CPU performance when Thunderbolt 3 eGPU connected | Native Windows 10  

  RSS

James Knight
(@james_knight)
Eminent Member
Joined: 6 months ago
 

I have been racking my brain in trying to resolve this issue and at one point before my main board died and needed replacing everything was working. This was after a long week of Error Code 12 issues. That I have successfully identified the conflict and am now able to ensure stability of the eGPU working when I boot up.

So with my current issue I am not sure what is different. Apart from a fresh build of windows. All Firmware is brought up to date including drivers that I was using before.

The issue...

Whenever I go to load a game or place any type of strain whether that be something as simple as using an internet browser all more CPU cores lock at 0.40Ghz. Adjusting power plans changing power source types and sizes do not make a difference. Yet strangely and what baffles me more. Is that when just typing this thread or in notepad my clock speed will jump up to about 1.2Ghz per core. Yet as soon as I run a CPU stress test it rolls back to 0.40Ghz.

I know of one other user that has witnessed this on this forum but I am hoping that someone might be able to help me think out of the box and troubleshoot this or even better know the answer...

Note that my machine works perfectly fine when the eGPU is not connected.

CPU Throttled when pressured
System operating idle

 

 

 

 

Setup: Dell Latitude 7400 | i7-8665U | 32GB DDR4 | M2.sata 512GB |
iGPU: UHD 620 | eGPU: Nvidia RTX 3070 FE | Asus XG Station Pro | Thunderbolt 3 (15D9) : NVM 44.00


itsage liked
ReplyQuote
James Knight
(@james_knight)
Eminent Member
Joined: 6 months ago
 

I am not sure if this will just end up going into the ether, but maybe someone will discover this thread and make use of the information to come and better find an actual solution instead of the work around I have found.

My issue outlined above is possibly related to the AMD Xconnect Technology playing with the Intel CPU Power management settings. I have been racking my brain for weeks and with nothing to lose I stumbled across installed Intel Extreme Tuning Utility. Although for my processor it seems like most options are locked off. However, when I log into Windows and load Intel XTU with my eGPU connected. It reported that my system's Turbo Boost Power Max is equal to 3W which means none of my processors go beyond 0.40Ghz due to Power Limit Throttling.

So far I have yet to find the actual automated fix. At this present moment in time. I have to log in and patiently load Intel XTU. Once it loads I set my Turbo Boost Power Max to 30W. As soon as I hit apply, all works back as I would expect. For me as I have set 30W in the past. This is what is shown when I load the application. So in order to get it to kick in I set it to 30.25W apply then back to 30W then apply.

I also match this on my Turbo Boost Short Power Max (Not really required but this keeps my Laptop from going beyond 90 Degrees Celsius). This works for me.

TDP Limitation

 

Setup: Dell Latitude 7400 | i7-8665U | 32GB DDR4 | M2.sata 512GB |
iGPU: UHD 620 | eGPU: Nvidia RTX 3070 FE | Asus XG Station Pro | Thunderbolt 3 (15D9) : NVM 44.00


ReplyQuote
James Knight
(@james_knight)
Eminent Member
Joined: 6 months ago
 

So the hard truth is that the issue is definitely caused by DPTF (Intel "Dynamic Platform Thermal Framework") Although, I like some, would say this is also not a permanent fix, but for me it has increase my boot to login to a usable system by miles.

 

I found a website the referred to disabling DPTF permanently and preventing it from reinstalling. The task was quite easy as it goes and it can be fully reverted (tested this).

The entire article I found is;  https://bradshacks.com/disable-dptf/  

 

The fix for me was installing the "NoDPTF.reg" referenced registry file which prevents windows from being able to install the DPTF within device manager.

 

Then within 'Device Manger' under 'System Devices' I located 'Intel(R) Dynamic Platform and Framework Processor Participant' Right Button Click (menu click) selecting uninstall device. I also ticked the box for delete the drivers.

Device Manager DPTF

Once I rebooted my machine all is well. I am left with one device within 'Device Manager' as uninstalled stating 'PCI Data Acquisition and Signal Processing Controller'

Device Manager after DPTF disable

My clock speeds operate normal, my machine is set to optimised thermal management within Dell Power Manager and via Windows it is set to best performance. Under benchmark my system records a single value of 91*C but is stable. Which is the main thing.

 

Although I will continue to look this works for me for the moment.

Setup: Dell Latitude 7400 | i7-8665U | 32GB DDR4 | M2.sata 512GB |
iGPU: UHD 620 | eGPU: Nvidia RTX 3070 FE | Asus XG Station Pro | Thunderbolt 3 (15D9) : NVM 44.00


ReplyQuote
Golgo
(@golgo)
Eminent Member
Joined: 3 years ago
 

Hey man, I had a similar problem, see:

https://egpu.io/forums/thunderbolt-enclosures/cpu-i7-10510u-clock-randomly-drops-after-egpu-razer-core-x-is-connected/#post-84545

Thanks to your link, I saw that ThrottleStop seems to have an option that also solves the problem and so far, it seemes to work for me.

 

Thanks again and maybe that info could also be an easier solution for you too!

To do: Create my signature with system and expected eGPU configuration information to give context to my posts. I have no builds.

.

ReplyQuote
GovGeek
(@govgeek)
New Member
Joined: 3 months ago
 
Posted by: @james_knight

I am not sure if this will just end up going into the ether, but maybe someone will discover this thread and make use of the information to come and better find an actual solution instead of the work around I have found.

My issue outlined above is possibly related to the AMD Xconnect Technology playing with the Intel CPU Power management settings. I have been racking my brain for weeks and with nothing to lose I stumbled across installed Intel Extreme Tuning Utility. Although for my processor it seems like most options are locked off. However, when I log into Windows and load Intel XTU with my eGPU connected. It reported that my system's Turbo Boost Power Max is equal to 3W which means none of my processors go beyond 0.40Ghz due to Power Limit Throttling.

So far I have yet to find the actual automated fix. At this present moment in time. I have to log in and patiently load Intel XTU. Once it loads I set my Turbo Boost Power Max to 30W. As soon as I hit apply, all works back as I would expect. For me as I have set 30W in the past. This is what is shown when I load the application. So in order to get it to kick in I set it to 30.25W apply then back to 30W then apply.

I also match this on my Turbo Boost Short Power Max (Not really required but this keeps my Laptop from going beyond 90 Degrees Celsius). This works for me.

TDP Limitation

 

I'm so glad you posted this issue, I've been having the same exact issue on a very similar laptop model! I've scoured the interwebs and it wasn't until I noticed the Xconnect running that I changed my search criteria and finally ended up with your post! THANK YOU! I had been launching Intel XTU after waiting 10min to log in and changing the wattage from 3v to the default 22w, and everything would be fine... Until I rebooted with the eGPU still connected. 

I'm am brand new to eGPU's and just bought a used Razer X Chroma with a Radeon rx 5700 xt and was beginning to think there was a reason why it was sold so affordable. I knew it was tied to the problem because as soon as I eliminated the eGPU, the laptop was happy, even on the Dell TB19 dock. But I just wasn't sure yet and hadn't found anyone else with the issue. 

Thanks again! Smile   

This post was modified 3 months ago

Razer Core X Chroma w/XFX Radeon RX 5700 XT THICC III Ultra


ReplyQuote
James Knight
(@james_knight)
Eminent Member
Joined: 6 months ago
 

@govgeek

 

I would recommend reviewing the latter post I published regarding DPTF (Intel "Dynamic Platform Thermal Framework"). This has prevented me from having to deal with the slow login times as it stops the system from placing the 3W limitation. I find myself now just using Intel XTU to control the thermal throttling so that it does not perform a huge drop in CPU frequency during gaming that causes lag. I also found that with my original work around. At random intervals my CPU 3W limitation would just reappear. So making the changes to the DPTF has created a more stable permanent work around.

I also thank you for taking the time to reply to the thread. As it means all my pain of hitting brick walls to find a solution is now helping others.

 

Setup: Dell Latitude 7400 | i7-8665U | 32GB DDR4 | M2.sata 512GB |
iGPU: UHD 620 | eGPU: Nvidia RTX 3070 FE | Asus XG Station Pro | Thunderbolt 3 (15D9) : NVM 44.00


ReplyQuote
James Knight
(@james_knight)
Eminent Member
Joined: 6 months ago
 

@golgo

Thank you for replying and I apologise for the late response as I have been having issues logging back into the site.

I tried ThrottleStop but for some reason I could not get it to play ball. So any tips settings or pointers I am sure will be greatly received on this thread.

 

Setup: Dell Latitude 7400 | i7-8665U | 32GB DDR4 | M2.sata 512GB |
iGPU: UHD 620 | eGPU: Nvidia RTX 3070 FE | Asus XG Station Pro | Thunderbolt 3 (15D9) : NVM 44.00


ReplyQuote
Golgo
(@golgo)
Eminent Member
Joined: 3 years ago
 

@james_knight

No worries mate, for me it seems the Throttle Stop option under FIVR called "Disable and Lock Turbo Power Limits" has done the trick. Basically just check the box, save it and problem solved. I tried it manually multiple times before connecting to the egpu, when it worked every time. Then I simply saved the setting for startup and haven't had a problem ever since.
Didn't need to change anything or uninstall anything else.

Let me know it that also works for you, would be nice to know if that is an actually valid solution for more than just certain cases.

To do: Create my signature with system and expected eGPU configuration information to give context to my posts. I have no builds.

.

ReplyQuote
s_kywalker
(@s_kywalker)
New Member
Joined: 3 months ago
 
Posted by: @golgo

@james_knight

No worries mate, for me it seems the Throttle Stop option under FIVR called "Disable and Lock Turbo Power Limits" has done the trick. Basically just check the box, save it and problem solved. I tried it manually multiple times before connecting to the egpu, when it worked every time. Then I simply saved the setting for startup and haven't had a problem ever since.
Didn't need to change anything or uninstall anything else.

Let me know it that also works for you, would be nice to know if that is an actually valid solution for more than just certain cases.

@golgo, Wow, thanks, this helped me a lot. I had some slight stuttering in games. This solved it. 

Using Razer X Chroma with GeForce 1660Ti and HP EliteBook x360 1030 G3 (i7-8550U)


ReplyQuote
Golgo
(@golgo)
Eminent Member
Joined: 3 years ago
 

@s_kywalker, glad to hear it man, sounds like it is a valid solution for more ppl. then, nice!

 

To do: Create my signature with system and expected eGPU configuration information to give context to my posts. I have no builds.

.

ReplyQuote