Troubleshooting - Razer Core X Chroma, RTX 2070 and new Intel NUC 10 i7FNH
 
Notifications
Clear all

Troubleshooting - Razer Core X Chroma, RTX 2070 and new Intel NUC 10 i7FNH  

  RSS

johnnyUK
(@johnnyuk)
New Member
Joined: 1 month ago
 

Hi guys

Curious one...all works on my Dell XPS 13 9380, but with my new NUC with latest BIOS, drivers, windows updates etc, this is what happens:

 

1. eGPU enclosure is connected to NUC via TB3

2. Windows 10 boots, but APPEARS to freeze on logo

3. NUC attaches to my Bluetooth speaker so I know it's booted up.

4. I enter my PIN number as if the login screen is in front of me, but it's still on the logo screen and press Enter

5. The desktop appears in all its glory and all is good!

6. Reboot Windows in Safe Mode - all works fine (apart of the Safe Mode limitation obvs)

 

I have used Nvidia Control panel into Max Performance under Power Management mode and switched off PCI Link Power Mgt in Windows Power Settings per other troubleshooting guides.

 

Obvious question:  why is screen only displaying AFTER login?

 

Thanks!

 

John

 

This topic was modified 1 month ago

Pending: Add my system information and expected eGPU configuration to my signature to give context to my posts


ReplyQuote
itsage
(@itsage)
Illustrious Member Admin
Joined: 3 years ago
 

@johnnyuk, Which version of Thunderbolt Control Center are you running on this NUC? Can you check in the BIOS to see if there's settings on Thunderbolt that you can change? There may be pre-boot support and other settings to help with the logo freeze.

 

external graphics card builds
best laptops for external GPU
eGPU enclosure buyer's guide


ReplyQuote
johnnyUK
(@johnnyuk)
New Member
Joined: 1 month ago
 

Hi!  Thanks for your advice.

 

I have version 1.0.20.0 of the app and it says that I don't need to approve the devices, they will be automatically connected.  Is there a later version?

 

I can't see anything obvious in the BIOS but will do some more research.  

 

Thanks again

 

John

 

Pending: Add my system information and expected eGPU configuration to my signature to give context to my posts


ReplyQuote