[Unboxing] AORUS RTX 3080 Gaming Box Thunderbolt 3 eGPU
 
Notifications
Clear all

[Unboxing] AORUS RTX 3080 Gaming Box Thunderbolt 3 eGPU  

 of  7
  RSS

mayatola
(@mayatola)
Active Member
Joined: 2 months ago
 

@itsage

Thunderbolt Controller Center is 1.0.30.0. Driver version is 1.41.987.0. Security Level: Kernal DMA Protection (SL1).

Is there anything I can update or change?

 

To do: Create my signature with system and expected eGPU configuration information to give context to my posts. I have no builds.

.

ReplyQuote
itsage
(@itsage)
Illustrious Member Admin
Joined: 4 years ago
 

@mayatola, You can try changing Security Level to No Security (SL0).

 

external graphics card builds
best laptops for external GPU
eGPU enclosure buyer's guide

 
2021 15" ASUS TUF Dash F15 [11th,4C,H] + RX 6900 XT @ 32Gbps-M2 (ADT-Link R43SG) + Win10 2004 [build link]  


ReplyQuote
mayatola
(@mayatola)
Active Member
Joined: 2 months ago
 

@itsage

Thanks. I tried changing the security but nothing. I did manage to find the latest Thunderbolt Controller Driver (1.41.1054.0) and install that. And I changed the settings in Device manager for the thunderbolt to not let it put the device to sleep if it is drawing too much power. After doing that, I connected and still got the same on/off haywire everything, but there was no BSOD this time. So I finally installed the desktop version Nvidia drivers and all seemed to be good. I loaded into my wife's game (Spellforce 3) and it was actually working, the 3080 was doing the work and it was running the game at a locked 4k60. Then I loaded into an actual map and it crashed with some render or dll error or something like that. Still no BSOD though. Rebooted and when I got back into Windows, the Gaming Box was no longer detected. It was physically plugged in, but the TB3 control center showed it as not connected. I tried the reset switch and also physically unplugging the power cord (also unplugging the TB3 cable). After trying numerous times to reset the Gaming Box and plug it into the laptop, it was totally unresponsive. It seems like it bricked? I already packed it up and sent it back to Newegg. I think it has to be a defective unit. Fingers crossed they have a replacement sometime soon and I'll come back and let you know if it's working. Thanks again for all of your help.

To do: Create my signature with system and expected eGPU configuration information to give context to my posts. I have no builds.

.

ReplyQuote
AndreiD2017
(@andreid2017)
Active Member
Joined: 3 years ago
 

@itsage

 

Hi,

I have a similar egpu only with a 3090 inside (two eGPUs in fact), and I have a strange issue that lead to one of them to die out on me. I posted it on Reddit: https://reddit.com/r/eGPU/comments/kzadka/totally_disappointed_by_the_aorus_3090_gaming_box/

 

I have a question for you: did you use with your setup a different TB cable or the one that came in the box and did you use a display port or hdmi connection to your display?

To do: Create my signature with system and expected eGPU configuration information to give context to my posts. I have no builds.

.

ReplyQuote
itsage
(@itsage)
Illustrious Member Admin
Joined: 4 years ago
 

@andreid2017, I've used different Thunderbolt 3 cables (including the .5m one that came with the RTX 3080 Gaming Box). It's also been used through DisplayPort and HDMI cables. DisplayPort has better compatibility with higher resolution and refresh rates.

I can't comment on how the PSU would handle the more powerful RTX 3090. I have not encountered any issues. Some members have reported a loose cooling fan connector but that doesn't seem to be the case with your units. RMA for an exchange may be the way to go.

 

external graphics card builds
best laptops for external GPU
eGPU enclosure buyer's guide

 
2021 15" ASUS TUF Dash F15 [11th,4C,H] + RX 6900 XT @ 32Gbps-M2 (ADT-Link R43SG) + Win10 2004 [build link]  


ReplyQuote
mayatola
(@mayatola)
Active Member
Joined: 2 months ago
 

@AndreiD2017

Wow, looks like you have a similar problem as my wife and me. After constant crashes, the damned thing died on us too. We only used the TB3 cable that came with the unit. No external monitor with HDMI or Display port. I actually was thinking about trying it just to see if it would work, but the thing died on us and doesn't connect anymore. We already sent it back to Newegg and are waiting for a replacement.

To do: Create my signature with system and expected eGPU configuration information to give context to my posts. I have no builds.

.

ReplyQuote
Matthew Kwong
(@matthew_kwong)
Eminent Member
Joined: 4 months ago
 

@itsage, assume my laptop has TB4 ports, if I use a TB4 cable instead of the TB3 cable that comes with the box, will that make any differences (e.g. in terms of performance)?

 

This post was modified 2 months ago

eGPU newbie
Expected setup:
Lenovo ThinkPad X1 Carbon Gen 9
Gigabyte AORUS RTX 3080 Gaming Box


ReplyQuote
itsage
(@itsage)
Illustrious Member Admin
Joined: 4 years ago
 

@matthew_kwong, It will not make a difference. The total throughput is at the TB3 enclosure end (firmware). Intel capped that to 22Gbps. 

 

external graphics card builds
best laptops for external GPU
eGPU enclosure buyer's guide

 
2021 15" ASUS TUF Dash F15 [11th,4C,H] + RX 6900 XT @ 32Gbps-M2 (ADT-Link R43SG) + Win10 2004 [build link]  


ReplyQuote
Matthew Kwong
(@matthew_kwong)
Eminent Member
Joined: 4 months ago
 

I received my Gaming Box. Run a few tests and so far I'm happy with that. My 5-year-old laptop doesn't have a TB port so I have to borrow one from my company to test it.

 

However, when I attempted to do an OC scan with the Gigabyte software, the scan failed almost immedately. Since I don't see any issue when doing the benchmarks and VRAM test, I assume that is due to some conflicts with my cooperate laptop (you know, all those security software. encryption, antivirus, etc).

 

Have anyone faced the same issue?

eGPU newbie
Expected setup:
Lenovo ThinkPad X1 Carbon Gen 9
Gigabyte AORUS RTX 3080 Gaming Box


ReplyQuote
AndreiD2017
(@andreid2017)
Active Member
Joined: 3 years ago
 

@mayatola 

 

I'm sorry to see that others have the same issue! I was hoping that this is a one off situation. Please report back when new units arrive and if you see the same behavior.

 

@matthew_kwong

 

From my experience that Gigabyte software is pure crap. On one of my MBP, the 2017 15" it works (sometimes) but it sluggish, on the other MBP 2020 16" it doesn't work at all, meaning that whenever I run it, it briefly appears in the taskbar, showing the Gigabyte/Aorus logo and then suddenly disappears, probably crashing almost instantly upon launch, and it does this every freaking time, freshly rebooted Windows or not, with latest updates to the OS and drivers.

This post was modified 2 months ago

To do: Create my signature with system and expected eGPU configuration information to give context to my posts. I have no builds.

.

ReplyQuote
 of  7