[Unboxing] Mantiz Saturn Pro II MZ-03 Thunderbolt 3 eGPU Enclosure (US$299 RRP)
 
Notifications
Clear all

[Unboxing] Mantiz Saturn Pro II MZ-03 Thunderbolt 3 eGPU Enclosure (US$299 RRP)  

 of  45
  RSS

Stefan Ried
(@stefan_ried)
Active Member
Joined: 3 months ago
 
Posted by: @stefan_ried
Posted by: @itsage

@stefan_ried, The TBT controller firmware versions look right. Describe your USB peripherals connection in full detail and condition in which you're experiencing issues.

 

I am happy to supply as much info as possible.

 

The Sound Card is a semi-professional RME USB Sound card with latest firmware and drivers.

It is a very common card in Europe: https://www.rme-audio.de/babyface-pro-fs.html

 

....

 

Further information on the USB issues described above.

I experienced the same issues with the USB Sound Card on a Razer Core X Chroma

I hoped to get rid of it on the Mantiz. But it is the same.

Thanks

To do: Create my signature with system and expected eGPU configuration information to give context to my posts. I have no builds.

.

ReplyQuote
Stefan Ried
(@stefan_ried)
Active Member
Joined: 3 months ago
 

I've got a pointer from the Mantiz support, that it might be an EMI noise problem. The AMD 5700XT creates a lot of "noise" not only audio, but also electromagnetic.

So, shorter USB cables with an ferrit filter will be my next trail.

 

This post was modified 1 month ago

To do: Create my signature with system and expected eGPU configuration information to give context to my posts. I have no builds.

.

ReplyQuote
dktorr
(@dktorr)
New Member
Joined: 1 month ago
 

@mymantiz_john

***I just ordered the Mantiz Saturn Pro II a few minutes ago...***

 

I am currently running on Core X Chroma, with RX 580 on my Thinkpad X1 that has 4-lane thunderbolt...  I have the following plugged in this eGPU:

1.  Logitech BRIO webcam

2.  USB Mic

3.  USB fan to help cool the laptop while connected to 1 TBport.

Mouse/Keyboard are connected directly to Laptop via Bluetooth...

MY ONLY PROBLEM with this setup is that the BRIO webcam would only work for about 2 minutes, then the video LAGS a LOT!... I cannot even use the webcam on ZOOM, which is crucial nowadays.

 

***QUESTION:  Does the new Mantiz Saturn Pro II solves this USB lagging/webcam-zoom issues that the other eGPU's like this Core X Chroma has?  (If so, how will it solve it/ how is it better than the razer I am planning to return? hehe.)***

 

 

 

 

To do: Create my signature with system and expected eGPU configuration information to give context to my posts. I have no builds.

.

ReplyQuote
Mymantiz_John
(@mymantiz_john)
Vendor
Joined: 4 years ago
 
Posted by: @dktorr

@mymantiz_john

***I just ordered the Mantiz Saturn Pro II a few minutes ago...***

 

I am currently running on Core X Chroma, with RX 580 on my Thinkpad X1 that has 4-lane thunderbolt...  I have the following plugged in this eGPU:

1.  Logitech BRIO webcam

2.  USB Mic

3.  USB fan to help cool the laptop while connected to 1 TBport.

Mouse/Keyboard are connected directly to Laptop via Bluetooth...

MY ONLY PROBLEM with this setup is that the BRIO webcam would only work for about 2 minutes, then the video LAGS a LOT!... I cannot even use the webcam on ZOOM, which is crucial nowadays.

 

***QUESTION:  Does the new Mantiz Saturn Pro II solves this USB lagging/webcam-zoom issues that the other eGPU's like this Core X Chroma has?  (If so, how will it solve it/ how is it better than the razer I am planning to return? hehe.)***

 

 

 

 

Webcam lags highly related with EMI interference. It depends. 

One or our customer luckily has 2 webcam to compared, one is lag but the other isn't by using Mantiz Saturn Pro V2 eGPU. 

Mantiz: ● ●


ReplyQuote
dktorr
(@dktorr)
New Member
Joined: 1 month ago
 

@mymantiz_john

I have an older setup with Lenovo Graphics Dock (1050 card built in)... with all the same connected USB devices... and it works perfectly for the past 2 years!!!  (only problem is it's OLD 1050 card)...

by cross-referencing the chipsets of this old graphics dock VS the new Mantiz Saturn Pro II -  it seems like the Lenovo one has Winbond EEPROM chipset... everything else it's good...

 

Does Mantiz Saturn Pro II have Winbond EEPROM?

Any other thoughts on why my old setup works?  I'm hoping Mantiz solutions works better 

 

To do: Create my signature with system and expected eGPU configuration information to give context to my posts. I have no builds.

.

ReplyQuote
Mymantiz_John
(@mymantiz_john)
Vendor
Joined: 4 years ago
 
Posted by: @dktorr

@mymantiz_john

I have an older setup with Lenovo Graphics Dock (1050 card built in)... with all the same connected USB devices... and it works perfectly for the past 2 years!!!  (only problem is it's OLD 1050 card)...

by cross-referencing the chipsets of this old graphics dock VS the new Mantiz Saturn Pro II -  it seems like the Lenovo one has Winbond EEPROM chipset... everything else it's good...

 

Does Mantiz Saturn Pro II have Winbond EEPROM?

Any other thoughts on why my old setup works?  I'm hoping Mantiz solutions works better 

 

nothing related with the EEPROM. But related with what graphic card you used. Graphic card generate lots of EMI, and also USB 3.0 is well known " high sensitivity " interface. If your accessories are not well protected with EMI ( limited only to Webcam, USB Audio card ) then it will be effected by the noise from graphic card. 

You can try to remove the graphic card and test your webcam & USB audio amplifier to compared. 

Mantiz: ● ●


ReplyQuote
dktorr
(@dktorr)
New Member
Joined: 1 month ago
 

@mymantiz_john

 

Got it thanks!

Will installing a "Clip-on Ferrite Ring Core RFI EMI Noise Suppressor Cable Clip" in the USB cables of the BRIO Webcam and the USB mic work?

 

 

To do: Create my signature with system and expected eGPU configuration information to give context to my posts. I have no builds.

.

ReplyQuote
Gerax
(@gerax)
Active Member
Joined: 3 months ago
 

Hello,

 

got mine delivered today. Looks like a solid piece, even though I haven't opened it up yet to install the GPU (still waiting for the GPU to arrive).

Now, a few issues I'm encountering: network doesn't work (I have tried to switch to USB LAN in the Network preferences of OSX, but no luck, I'd appreciate some help on settings here whether to use DHCP or other protocols and IP address), as do USB ports, both on front and rear, devices connected to those don't turn on and show up.

Is this because I'm on Mojave (10.14.6)?

Thanx

This post was modified 1 month ago

To do: Create my signature with system and expected eGPU configuration information to give context to my posts. I have no builds.

.

ReplyQuote
Arzen
(@arzen)
Trusted Member
Joined: 3 years ago
 

@itsage, @mymantiz_john -- I just tested all my USB ports and not a single port (including the back of the eGPU) will charge an iPhone while connected. I can do data stuff just fine, but there is not enough power to charge the device -- it shows the iPhone is charging but the battery just drains anyway.

Is this expected behavior? 

I'm using a known working cable that I can connect and charge with on another USB port/computer. And the same iPhone.

@gerax, check my previous post for drivers for the Ethernet.

@mac_editor, Any chance that you tested your Front/Rear USB ports to see if they'll charge a phone?

My iPhone says it is charging when plugged into any of the ports, but none of them actually charge the phone (I left it in each port for over 5 minutes) -- however, normal data operations appear to be working in my limited testing.

 

This post was modified 1 month ago

MacBook Pro 16" - 2.3 i9, 16GB, 1TB, 5500m (I added thermal pads to the VRMs); Mantiz Saturn Pro w/ PowerColor Red Devil 5700 XT (previously, a Gigabyte RX 580 Gaming Box) + LG OLED C9


ReplyQuote
Gerax
(@gerax)
Active Member
Joined: 3 months ago
 

@Arzen, there shouldn't be any drivers for the LAN on Mac, unless Mantiz manages that in a different way.

USB ports don't work as well (nor front or rear). In the tech specs I see the minimum system requirements is OSX 10.15.5, I'm a bit hesitant to upgrade to Catalina as I have my system very stable and smooth on 10.14.6 with all the audio and video apps I use working flawlessly...I heard some pretty rough stories about Catalina...

@mymantiz_john, as I wrote above my Saturn has been delivered today, but aside hooking it up and using it as a big power supply I haven't been able to have anything else working, neither LAN nor USB ports.

I still haven't put the GPU inside, does this make any difference? Shouldn't I still be able to use the accessory ports and connections?

My MacBook Pro is a 15" 2018 running OSX Mojave 10.14.6, is an upgrade to Catalina "mandatory" to have the Saturn working?

Thanx

To do: Create my signature with system and expected eGPU configuration information to give context to my posts. I have no builds.

.

ReplyQuote
 of  45