[Unboxing] Mantiz Saturn Pro II MZ-03 Thunderbolt 3 eGPU Enclosure (US$299 RRP)
 
Notifications
Clear all

[Unboxing] Mantiz Saturn Pro II MZ-03 Thunderbolt 3 eGPU Enclosure (US$299 RRP)  

 of  52
  RSS

fervorous
(@fervorous)
Active Member
Joined: 10 months ago
 

For whoever is thinking to buy this product, please beware. I received a defective unit and when I opened a dispute through Paypal the seller agreed to replace the unit. After accepting the offer for the item to be replaced they stopped replying me, that was on 6th of November 2021. I tried emailing them many times and through the customer support but so far there is no reply. I hope people who has seen this review will think twice about buying this because up to now I have spend over $400 for a big box of junk.

To do: Create my signature with system and expected eGPU configuration information to give context to my posts. I have no builds.

.

ReplyQuote
(@tom_b)
Trusted Member
Joined: 2 years ago
 

Can you supply some images of what's wrong? Maybe we can help.

This post was modified 7 months ago

TomB, AW51m R2 with an Akitio Node Titan (3080 OC inside). Why? Because I like having a Desktop At home and Gaming on the go but, I hate using P2P to share files.


ReplyQuote
fervorous
(@fervorous)
Active Member
Joined: 10 months ago
 

@tom_b, right now I cannot give you the pictures as I keep it in my warehouse. However I can tell you that the unit looks perfectly fine physically and visually, it just doesn't turn on or get detected by the PC. The customer service even acknowledged that the unit is defective (Dead on arrival) and promised to replace it.

I just contacted Paypal and this seller is confirmed to be tricky and they gave me replacement offer through Paypal just to close the dispute case so that it would not get escalated to Paypal, please other buyers if you bought from them make sure you receive the item in working condition and buy it through third party like Amazon, I made a mistake buying it straight from their website. I am still waiting for the Mantiz team, hoping their good faith as a seller but I don't think they will really send the replacement unit. In conclusion, just be wary if you want to buy this product you can read the other's review about their after service.

This post was modified 7 months ago

To do: Create my signature with system and expected eGPU configuration information to give context to my posts. I have no builds.

.

ReplyQuote
Trevor MONAGHAN
(@trevor_monaghan)
Active Member
Joined: 8 months ago
 

I bought the Mantiz MZ-03 Saturn Pro EGPU ( V2 ) mid February 2022.

It is paired with a Reference AMD Radeon XR6900XT & a MacBook Pro 2019.

The AMD is linked directly from the Display Port to the 4K Dell UltraSharp U3223QE.
The Mantiz MZ-03 is coupled directly using the Thunderbolt 3 Port to the MacBook Pro.
The RX6900XT is detected by macOS as the primary Graphics Card.

However, the Internal SSD isn't & there is a problem with the ethernet speed. It is almost as if the whole Unit wasn't supplied with enough power to sustain the demand.

Whether I plug a LAN cable to the LAN Port of the eGPU Enclosure or instead two ethernet USB adapters, the maximum speed is about 350Mb/s.

I tested two ethernet USB Adapters with the same LAN cable plugged to the back of the 4K Dell Monitor & the Speed can reach up to 1.1Gb/s.

Therefore, there isn't an issue with the Cabling or the Network arrangement.
In addition, I have tried several other Lan cables, and Lan Ports available from the Asus Router.

So, I am confused for not understanding why the Lan speed doesn't go beyond 350Mb/s & adding to that the SSD isn't detected at all. I checked that the cabling inside the eGPU was comfortably attached & well arranged.

So I am very confident that it has got nothing to do with my own installation. For example, for the Lan speed not to exceed 350Mb/s is rather particular.

Is there a firmware update or something that could fix that?
What bothers me the most is that Mantiz when emailed at support@mymantiz.com, never responds.

Consequently, in the United Kingdom, under Section 75 of the Consumer Credit Act 1974, the Credit Card company is jointly & severally liable for any breach of Contract or Misrepresentation by the Retailer or Trader.

This Right is particularly useful if the Retailer or Trader has gone bust, or it doesn't respond to my letters or phone calls. 

Section 75 of the Consumer Credit Act also applies to Foreign transactions as well as goods bought online, by telephone or mail order for delivery to the UK from overseas.

Not given the option, Mantiz has until the 16 March to rectify or recall the faulty product otherwise there will be a charge back of $379.00 USD

To do: Create my signature with system and expected eGPU configuration information to give context to my posts. I have no builds.

.

ReplyQuote
(@aleksei_kuznetsov)
Active Member
Joined: 5 months ago
 

Want to share my experience, which looks quite similar to what people have.

Ordered this box on Feb 15th, got it quite fast. However, GPU (1060) is not visible from Surface Pro 8, evens fans are silent.

Tried with stock T3 cable, another T3 cable, T4 cable. Tried using PSU from the desktop. No nothing. USB port and PD works alright, but not the GPU. Sent an email to their support, no response for two weeks.

This looks like a scam, I got a faulty device for a price, and silent support on the other end =/

 

To do: Create my signature with system and expected eGPU configuration information to give context to my posts. I have no builds.

.

ReplyQuote
fervorous
(@fervorous)
Active Member
Joined: 10 months ago
 

I have an update for my side, after much troubleshooting with the power supply, reinserting all the internal cables of the enclosure and replacing the stock TB3 cable, I got my Mantiz Saturn working now. I can say I am happy with the enclosure but still unhappy with the customer support and service they provided.  @aleksei_kuznetsov have you tried reinserting the internal cables like me? For me the test was to charge my phone with the TB cable from the enclosure, when I got it to charge my enclosure gets to work.

To do: Create my signature with system and expected eGPU configuration information to give context to my posts. I have no builds.

.

itsage liked
ReplyQuote
(@aleksei_kuznetsov)
Active Member
Joined: 5 months ago
 

@fervorous, I disassembled the whole box and replugged everything, as I changed the PSU also to troubleshoot which requires replugging stuff. The same setup works fine with Razer enclosure f.e. Mantiz just doesn't do anything with the GPU, even fans are not starting nor the device is visible in the target system.

I made a mistake and bought that directly from their site, so getting back the money is now almost impossible. I pushed my bank, they started the dispute, which forced the guy who owns this mantiz to write me a mail with pretty rude questions. I described the issue to him and he told me that he doesn't see any issue and stopped responding. Banks said because the owner hasn't provided me with the way to return the device they can't initiate a refund. 

 

To do: Create my signature with system and expected eGPU configuration information to give context to my posts. I have no builds.

.

ReplyQuote
Trevor MONAGHAN
(@trevor_monaghan)
Active Member
Joined: 8 months ago
 

This is no sense

My Credit Card Halifax Bank requested that I sent an email requesting for them to collect it within two weeks or a charge-back. In the end, I got the money back through chargeback and kept the device. Your Bank is as liable as the Retailer for breach of contract and misrepresentation under Section 75.  So don’t give up!!!!

 

To do: Create my signature with system and expected eGPU configuration information to give context to my posts. I have no builds.

.

ReplyQuote
fervorous
(@fervorous)
Active Member
Joined: 10 months ago
 

@aleksei_kuznetsov, you changed the PSU on the enclosure, did you do a paperclip test on the PSU before you put it into the enclosure? I did a paperclip test to know whether the stock PSU works. Try a different power cable as well. I am sorry to hear your issue, I bought it directly from the website as well through Paypal and had the same issue like you, however I managed to get it working through self troubleshooting, hope it also works with yours. Do you use the same thunderbolt cable for the Razer enclosure and it works on the Razer?

 

To do: Create my signature with system and expected eGPU configuration information to give context to my posts. I have no builds.

.

ReplyQuote
(@aleksei_kuznetsov)
Active Member
Joined: 5 months ago
 

@fervorous, I tried with both PSU, I took the other one from my working desktop, and put the PSU from the enclosure to the desktop, and everything works. So PSU is not an issue. Yeah, I did exactly the same setup with Razer and it works. Same cables, same laptop, same GPU. On mantiz though everything works except the GPU slot. USB, sata, power delivery works, but not the GPU. The device can even recognize the PCI-E devices connected after I plug in the cable, but not the GPU itself. Looks like controllers are ok, but probably the slot itself is malfunctioned, I dunno

 

To do: Create my signature with system and expected eGPU configuration information to give context to my posts. I have no builds.

.

ReplyQuote
 of  52