Why doesn't my Enclosure work with my MaBook Pro?
 
Notifications
Clear all

Why doesn't my Enclosure work with my MaBook Pro?  

  RSS

nicolamenicacci
(@nicolamenicacci)
New Member
Joined: 2 months ago
 

Hi,

I am sorry for starting my membership with a request of help but you are really my last hope.

For my 2017 (or 18) 13" MacBook Pro 8GB RAM (now with Big Sur) I bought a combo of OWC Mercury Helios FX650 with a Radeon RX 580 8 GB card. I got it through Ebay, still in warranty. I opted for that rather than the BlackMagic one, which was initially my choice. 300 dollars less was not bad.

I wish I had not done that. The enclosure works per se, but my Mac cannot see it. Or what it exactly does I don't know.

It can charge the Mac, and the enclosure starts. At first, I see the ECPU symbol on the upper bar, but it says "no GPU found" and then the icon disappeared after a bit. and nothing else happens.

I checked the hardware specifics of the Mac and the interesting thing is that the system seems to see something, but it identifies it as a monitor.  I wish I had the chance to upload those screenshot

I wonder if I should sell it again on Ebay and go for the Black Magic Egpu. Which is weird because that exact set-up was recommended by Apple.

Can you help? I have watched thousands of videos, and I do exactly what they say, i.e. plug and play. But nothing happens...

Thanks you all in advance..

2017 8GB MacBook Pro. Hoping to install my Helios FX 650 with Radeon 580, Big Sur 11.1


ReplyQuote
Eightarmedpet
(@eightarmedpet)
Noble Member Moderator
Joined: 4 years ago
 

@nicolamenicacci, lets see pics of how you've put it together and some screenshots from "system report".

Could be multiple things, but I'd wager a guess you haven't installed the card correctly.

No need to buy a Blackmagic.

 

2017 13" MacBook Pro Touch Bar
GTX1060 + AKiTiO Thunder3 + Win10
GTX1070 + Sonnet Breakaway Box + Win10
GTX1070 + Razer Core V1 + Win10
Vega 56 + Razer Core V1 + macOS + Win10
Vega 56 + Mantiz Venus + macOS + W10

---

LG 5K Ultrafine flickering issue fix

 
2018 Mac Mini [8th,6C,B] + RX 580 @ 32Gbps-TB3 (AKiTiO Node Lite) + Win10 20H2 [build link]  


ReplyQuote
nicolamenicacci
(@nicolamenicacci)
New Member
Joined: 2 months ago

ReplyQuote