XPS 13 9380/Akitio Node/RTX 2060 Error 12 and freezing
 
Notifications
Clear all

XPS 13 9380/Akitio Node/RTX 2060 Error 12 and freezing  

  RSS

bryant5968
(@bryant5968)
New Member
Joined: 11 months ago
 

I used to connect my XPS 13 with Razer Core X and RX 580 and everything works fine.

for some reason I sold both of them and today I got my new egpu enclosure and graphic card

But things doesn't went as smooth as previous build.

At first, I met the issue with Error 12 and struggled a little bit.

After I do fresh windows install and disabled Intel(R) PCI Express Root Port #5 - 9DBC(the one for SD card reader I believe)

the error had gone and I'm able to use the egpu now.

But now there is a issue that my computer can't boot with egpu connected

it would stuck at logo screen and I have to force shutdown the computer

and from time to time my computer would freeze while I'm using it with egpu connected, also required force shutdown.

Anyone had idea what's going on?

This topic was modified 11 months ago

To do: Create my signature with system and expected eGPU configuration information to give context to my posts. I have no builds.

.

ReplyQuote
qiensis
(@qiensis)
Active Member
Joined: 11 months ago
 

I have the XPS 13 7390 (basically the same as yours), and I connect an external monitor through a USB-C to HDMI adapter without an egpu. When the adapter is plugged in and I turn on the computer, it gets stuck on the logo screen and doesn't start "loading" unless I disconnect the adapter, wait for the "loading" symbol to show up, and then plug it back in.

Recently I have discovered that pressing keys on the keyboard during the boot process sometimes allows the computer to turn on with the adapter plugged in, but this has been unreliable. It still sometimes gets stuck at the logo.

Since the egpu is basically a (really beefy and powerful) display adapter, I imagine that a similar issue could be happening. Unplugging the adapter and plugging it back in is a bit of an annoying slowdown, but it is relatively easy to do each time the computer boots. I hope this helps!

2019 13" Dell XPS 13 7390 [10th,6C,U] + GTX 1660 Super @ 32Gbps-TB3 (ADT-Link R43SG * M.2-TB3) + Win10 [build link]  

ReplyQuote