Clear all

Help on Zorin 15.1  


Robert Ward
New Member
Joined: 2 years ago

I'm trying to get a Razer Core X + VisionTek AMD 5700XT + Dell XPS 13 7390 DE to work together in Zorin 15.1.

Zorin Troubles

Zorin comes with amdgpu (open source) preinstalled, but in attempting to troubleshoot, I've tried a couple of reinstalls from the official package here (thinking the driver could be at fault). The first time I ran this after a fresh install of Zorin, the installer compiled for my kernel (5.3.0-28-generic) and installed successfully. In all following attempts, it has failed to build for my kernel version (I tried amdgpu-pro after the open source version, to see if it made a difference, and it failed). Here is the output of `apt list --installed | grep amdgpu`:


Switcheroo Troubles

I followed the Ubuntu Hybrid Graphics wiki, adding `radeon.modeset = 1` to my boot params, updating `grub` and rebooting. I can see the controller in `lspci -nn | grep -E 'VGA|Display'` with the correct definition:

[Please login to see this]

When I try to list the directory, using the command, `sudo ls -l /sys/kernel/debug/vgaswitcheroo/switch` the result is:

`ls: cannot access '/sys/kernel/debug/vgaswitcheroo/switch': No such file or directory`

Also trying to run `xrandr --listproviders` gives only the UHD provider:

Providers: number : 1
Provider 0: id: 0x45 cap: 0x9, Source Output, Sink Offload crtcs: 3 outputs: 3 associated providers: 0 name:modesetting

Xorg Troubles

I created a conf file in `xorg.conf.d/`: using a modified version of the one here. I followed the linked guide, and ended up with this conf (and a few variations, none of which worked). When I start X11 (by logging out and back in or rebooting), it crashes and returns me to the login screen. I have to open a Wayland session to move that conf to the `disabled` dir I created there to get X11 working again.

The XServer logs aren't terribly helpful here, except that they say something about the kernel not supporting multi-VGA:

The `gpu-manager.log` may be more helpful: (according to this, the drivers may not be loading soon enough).

`dmesg` may be even more helpful:

Following the recommendation of adding nogpumanager to my boot flags didn't help, unfortunately.


Any help is appreciated!

This topic was modified 2 years ago

To do: Create my signature with system and expected eGPU configuration information to give context to my posts. I have no builds.


Reputable Member
Joined: 4 years ago


I believe in kernel 5.3 and its mesa version it doesn't include the firmware files for Navi support by default. If you didn't add these then that could be the issue. Upgrading to kernel 5.4 should fix this as well I think.

Mid-2012 13" Macbook Pro (MacBookPro9,2) TB1 -> RX 460/560 (AKiTiO Node/Thunder2)
+ macOS 10.15+Win10 + Linux Mint 19.1

2012 13" MacBook Pro [3rd,2C,M] + RX 460 @ 10Gbps-TB1 (AKiTiO Thunder2) + macOS 10.14.4 [build link]