How to force Steam to use eGPU? // EndeavourOS + KDE
 
Notifications
Clear all

How to force Steam to use eGPU? // EndeavourOS + KDE  

  RSS

(@sajid_ahmed)
Eminent Member
Joined: 3 years ago
 

This is my build.

Installed EndevourOS with KDE. On stock, with Nvidia proprietary drives, it is pretty much plug & play (it can hotplug if you make sure nothing is using the Nvidia eGPU), for rendering, but not for gaming.

Unsure if there is a way to force Steam to use the eGPU.

Anways, I installed egpu-switcher, set it to auto, logged out, and back in, and it is up and running fine on the eGPU, but launching native or proton games does not launch on eGPU for some reason.

 

Checking nvidia-smi does not report steam or any other games running on eGPU.

Sample Log:

[Please login to see this]

 

Performance is akin to running on iGPU, so I am sure something is fishy here.

2021 15" Lenovo Thinkbook 15 Gen 2 [11th,4C,G] + GTX 1060 @ 32Gbps-TB4 (Orico TOM2T3-G40 * ADT-Link R43SG) + Win10 [build link]  

ReplyQuote
(@alfonso_taboada)
New Member
Joined: 2 months ago
 

I seem to have the same problem. Did you find a solution?

2021 14" Lenovo Yoga 9i [11th,4C,G] + RTX 3060 @ 32Gbps-TB4 (Razer Core X) + Linux Arch [build link]  

ReplyQuote
(@theformigoni)
New Member
Joined: 4 months ago
 

@sajid_ahmed, have you tried with prime? On steam you can do:

[Please login to see this]

To avoid setting it for every game, you can export these variables on your .bashrc.

[Please login to see this]

If you use prime you can keep the egpu plug-and-play.

Have you followed this guide to configure the egpu? Make sure the output of xrandr --listproviders is correct.

 

Asus Zenbook 14 - UX425, RX 6600 XT eGPU (NVME), Arch Linux + SwayWM


ReplyQuote