No Picture on Monitors connected to eGPU but on the Notebook-Screen.
 
Notifications
Clear all

No Picture on Monitors connected to eGPU but on the Notebook-Screen.  

  RSS

Luminous
(@luminous)
New Member
Joined: 2 months ago
 

So i need a little bit help to troubleshoot this problem. I have no Picture on my two Monitors connected to the eGPU.

I use a T480s and a Razer Core X Chroma with a AMD RX580. Before i bought the Razer Core i tested the a setup with my T480s with a Sonnet Enclosure of a friend and his Nvidia Card. Everything works fine. Then i bought the Razer Enclosure and AMD Card but the Enclosure arrived earlier so i tested it with the Nvidia Card of my Flatmate. Everything works fine too. Until this Point i just used the egpu-switcher script from hertg.

Then the AMD Card Arrived and nothing works flawless. I get it to work sometimes but then i am not able to switch back or disconnect the Enclosure without freezing my Notebook and so on.
So here is the little history of what I've done. A first i doesn't work and at the troubleshooting i noticed the --override argument of the egpu-switcher recommended for AMD Cards. With this argument applied to the script, i was able to switch to the egpu and get a picture on one of the monitors. I than used a/xrandr to setup both monitors an everything was fine. I used the setup that evening, everything works fine an the performance was great. Then i shutdown the notebook and in the morning it wont boot up. I had to boot a ISO an changeroot to my system to switch back to internal.
Today i started a new Session and tried to fix this but i still get no Picture on the Monitors connected to the eGPU but on the embedded Monitor of my Notebook.
I switched to the eGPU and all screens are black (In the process to this point i am really good in using my computer blind or with a combination of ssh and blind). Via ssh i saw that Xorg actually started because i saw the lightdm (my greeter) process. Than i blindly logged in and started a terminal and piped the output of xrandr --prop into a file for the monitor identifier. Than i wrote a xrandr script in the ssh session to set the output to HDMI-1-3 and DVI-D-0 (the monitors attached to the eGPU) and piped the standard-output to a file and the standard-error to an other file so i can see in the ssh session if everything works. Xrandr returned 1 (no errors) but the screens are still black. I than noticed the internal Monitor had an other Identifier on the eGPU. Not eDP1 like on the internal card but eDPI-1-1. So i wrote the script to use this Monitor and xrandr returned 1 and this Monitor actually worked. So at this Point my eGPU renders my internal Screen but not the Screen directly attached.

And yes i am 100% sure i actually using the AMD card in the enclosure.

Update: Wanted to check again with the Nvidia Card from my Flatmate and it just works. Switching works, unplugging works without freezing, rebooting works, Screenlayout works just fine. At no Point i was able to perform all these with the AMD Card.

This topic was modified 1 month ago

To do: Create my signature with system and expected eGPU configuration information to give context to my posts. I have no builds.

.

ReplyQuote