Nvidia - fallen off the bus and is not responding to commands
 
Notifications
Clear all

Nvidia - fallen off the bus and is not responding to commands  

  RSS

Øystein Andresen-Sund
(@oystein_andresen-sund)
New Member
Joined: 2 months ago
 

Hi,

I'm running Ubuntu 20.04 on a Lenovo X13 with Nvidia GeForce RTX 2060 SUPER in the Thunderbolt cabinet Asus XG Station Pro.

The BIOS and Thunderbolt firmware is upgraded to the latest version and the eGPU is working perfectly in Windows.

I've managed to get the eGPU running in Ubuntu with the Nouveau driver. I've also installed egpu-switcher. Everything works fine except for performance in gaming.

When I install nvidia-driver-460 (or any other older version), I get the following repeated three times a second in DMESG:

[to. feb. 11 19:30:18 2021] nvidia: probe of 0000:0c:00.0 failed with error -1
[to. feb. 11 19:30:18 2021] NVRM: The NVIDIA probe routine failed for 1 device(s).
[to. feb. 11 19:30:18 2021] NVRM: None of the NVIDIA devices were initialized.
[to. feb. 11 19:30:18 2021] nvidia-nvlink: Unregistered the Nvlink Core, major device number 508
[to. feb. 11 19:30:18 2021] nvidia-nvlink: Nvlink Core is being initialized, major device number 508
[to. feb. 11 19:30:18 2021] nvidia 0000:0c:00.0: vgaarb: changed VGA decodes: olddecodes=none,decodes=none:owns=none
[to. feb. 11 19:30:18 2021] NVRM: The NVIDIA GPU 0000:0c:00.0
NVRM: (PCI ID: 10de:1f06) installed in this system has
NVRM: fallen off the bus and is not responding to commands.

The result is that I'm unable to log into Xorg. In 1 out of 10 times, Linux is able to load the Nvidia properitary driver. I've been unable to find out a pattern on why it sometimes works.

I've tried adding the following to grub in GRUB_CMDLINE_LINUX_DEFAULT:

pcie_ports=native pci=assign-busses,nocrs,realloc iommu=on rcutree.rcu_idle_gp_delay=2

I've spent many hours on figuring out this, so if anybody has a solution to this, I'd be very greatful. Thanks :).

This topic was modified 2 months ago

To do: Create my signature with system and expected eGPU configuration information to give context to my posts. I have no builds.

.

ReplyQuote
Øystein Andresen-Sund
(@oystein_andresen-sund)
New Member
Joined: 2 months ago
 

I had another crack at this today and went to BIOS Setup > Config > Thunderbolt 3 > Support in Pre Boot Environment = Enabled.

Seems like the problem is solved!

To do: Create my signature with system and expected eGPU configuration information to give context to my posts. I have no builds.

.

ReplyQuote