Video Playback Lagging with AMD EGPU
 
Notifications
Clear all

[Solved] Video Playback Lagging with AMD EGPU  

  RSS

ross
 ross
(@ross)
New Member
Joined: 7 months ago
 

Basically the title, 4k video, especially in full-screen is borderline unplayable. I've tested w/ VLC and it stutters pretty bad, and in YouTube basically any kind of video is unplayable in full-screen or larger windowed mode. The YouTube UI is also very laggy when in full-screen, if that helps. Not sure what's going on, if anyone has any ideas please let me know!

Here's some system info:

Kernel: 5.4.0-48 generic (although I did try 5.40-2x without success)

OS: Mint

GPU: Radeon VII

 

 

EGPU: Radeon VII in Razer Core X Chroma


ReplyQuote
nu_ninja
(@nu_ninja)
Reputable Member
Joined: 3 years ago
 

More info is needed if you want help fixing this. For example, are you using an external display connected to the eGPU and if you are, are you using any of the scripts from this forum or any other method of setting the eGPU as the primary display?

In previous versions of LM + firefox youtube would be laggy in fullscreen mode and I had to opt into Webrender and hardware compositing using flags in about:config. But since the latest update Mint 20 base and firefox 80+ I think this is on by default so there shouldn't be any need to do that.

Might as well mention checking to make sure the package: mint-meta-codecs is installed and updated

Keep in mind that video codec matters. Only H.264 and H.265 are hardware accelerated on AMD Vega and earlier. So videos from youtube that mostly stream in VP9 are expected to use the CPU to decode.

Edit: The flags I set in firefox about:config are:

gfx.webrender.all = TRUE

gfx.webrender.compositor = TRUE

Mid-2012 13" Macbook Pro (MacBookPro9,2) TB1 -> RX 460/560 (AKiTiO Node/Thunder2)
+ macOS 10.15+Win10 + Linux Mint 19.1

 
2012 13" MacBook Pro [3rd,2C,M] + RX 460 @ 10Gbps-TB1 (AKiTiO Thunder2) + macOS 10.14.4 [build link]  


ReplyQuote
ross
 ross
(@ross)
New Member
Joined: 7 months ago
 

@nu_ninja, changing gfx.webrender.all to true fixed it. For the VLC issue, I believe it can be resolved by changing the codecs, as you said. Thank you for your help!

 

EGPU: Radeon VII in Razer Core X Chroma


ReplyQuote