AKiTiO Node Pro + 5700 XT ... is the PSU enough?
 
Notifications
Clear all

AKiTiO Node Pro + 5700 XT ... is the PSU enough?  

  RSS

guyinsea
(@guyinsea)
Active Member
Joined: 2 months ago
 

Hello, I've looked around quite a bit but I am not able to know exactly what I should do.

I bought the AKiTiO Node Pro recently and I am now shopping for the graphics card. The Node has a 500W integrated PSU, but most of the graphics card brands states they need around 600+ you can see the exact specs of the ones I am looking at here:

Screen Shot 2020 08 03 at 11.26.11 PM

On the official compatibility list it doesn't actually have the Node Pro, but it says the max W to the graphics card is 400W, way lower than the 5700 XT requires. Which is either 500W according to this list, or 600W+ according to the sales website. https://www.akitio.com/information-center/node-gpu-compatibility

I also wonder if -- say I use my own charger (87W) instead of the charging through the eGPU, does the additional wattage to into the GPU? e.g. let's say it gives 400W plus the 60W that would go to the charging. I dunno if that makes any sense but maybe?

If neither of these solutions work - my options are either getting a worse card, recommendations? OR can I buy an external PSU dedicated to the graphics card? Meaning I'd have the Node Pro + the PSU on top of it or something like that, is that even possible?

Thanks a lot for reading!

2016 15" MacBook Pro (RP455) [6th,4C,H] + RX 5700 XT @ 32Gbps-TB3 (AKiTiO Node Pro) + macOS 10.15.5 & Win10 [build link]  

ReplyQuote
guyinsea
(@guyinsea)
Active Member
Joined: 2 months ago
 

I bought it anyway, it seems to work fine so far although I've only gotten it to work in macOS and ran some simple benchmarks. So no real load on it yet, will save that update for when/if I get it to work on Windows.

2016 15" MacBook Pro (RP455) [6th,4C,H] + RX 5700 XT @ 32Gbps-TB3 (AKiTiO Node Pro) + macOS 10.15.5 & Win10 [build link]  

Mini i5 liked
ReplyQuote
guyinsea
(@guyinsea)
Active Member
Joined: 2 months ago
 

Can also now confirm that it works fine while gaming in Windows 10

2016 15" MacBook Pro (RP455) [6th,4C,H] + RX 5700 XT @ 32Gbps-TB3 (AKiTiO Node Pro) + macOS 10.15.5 & Win10 [build link]  

Mini i5 liked
ReplyQuote