AMD Navi 7nm for eGPU - Radeon RX 5700 & RX 5700 XT
 
Notifications
Clear all

[Solved] AMD Navi 7nm for eGPU - Radeon RX 5700 & RX 5700 XT  

 of  43
  RSS

Christopher Straßer
(@christopher_straser)
Eminent Member
Joined: 2 years ago
 

As I said, don't try to override anything in 10000Controler. If you do that this can cause massive problems. Use this property injector instead.

 
Edit: Here is a demonstration of the effect undervolting has on macOS.
Testing machine is my Hackintosh (i7-8700k 4.7GHz, 32GB DDR4 4000MHz RAM, Gigabyte RX 5700 XT Gaming OC).
This post was modified 2 years ago

To do: Create my signature with system and expected eGPU configuration information to give context to my posts. I have no builds.

.

ReplyQuote
mac_editor
(@mac_editor)
Famed Member Moderator
Joined: 5 years ago
 
Posted by: @christopher_straser

As I said, don't try to override anything in 10000Controler. If you do that this can cause massive problems.

I was just overriding some of its fields in a codeless kext via controller personality (which is update-proof if adding/changing properties while matching same class as original driver, ex. IOPCITunnelCompatible key - I presume you meant macOS updates), not 10000Controller itself - similar manner of kext is generated by VGTab IIRC. Not sure how the kext you shared works (laptop is away, haven’t looked at it), but it probably isn’t codeless (I use the term “dummy” for this - since codeless kexts don’t show up on kextstat).

"Desultory reading is delightful, but to be beneficial, our reading must be carefully directed." — Seneca

Author: kryptonitepurge-wranglertbt-flashpurge-nvdaset-eGPU
Insights Into macOS Video Editing Performance
Launching Apps on Specific (e)GPUs on macOS

Master Threads:
2014 15-inch MacBook Pro 750M
2018 15-inch MacBook Pro

 
2019 13" MacBook Pro [8th,4C,U] + RX Vega 64 @ 32Gbps-TB3 (Mantiz Venus) + macOS 10.14.6 & Win10 [build link]  


ReplyQuote
Christopher Straßer
(@christopher_straser)
Eminent Member
Joined: 2 years ago
 

Oh I got you wrong then. And yes the one i shared is not a dummy Kext. But very useful for injecting device properties for multiple devices in one single Kext. I used it to inject PPTs in the past and it was always working.

To do: Create my signature with system and expected eGPU configuration information to give context to my posts. I have no builds.

.

ReplyQuote
mac_editor
(@mac_editor)
Famed Member Moderator
Joined: 5 years ago
 

@christopher_straser

Thank you for sharing that kext here!

I certainly appreciate your insights and look forward to your future contributions here. 

"Desultory reading is delightful, but to be beneficial, our reading must be carefully directed." — Seneca

Author: kryptonitepurge-wranglertbt-flashpurge-nvdaset-eGPU
Insights Into macOS Video Editing Performance
Launching Apps on Specific (e)GPUs on macOS

Master Threads:
2014 15-inch MacBook Pro 750M
2018 15-inch MacBook Pro

 
2019 13" MacBook Pro [8th,4C,U] + RX Vega 64 @ 32Gbps-TB3 (Mantiz Venus) + macOS 10.14.6 & Win10 [build link]  


ReplyQuote
BeardedBro
(@beardedbro)
Trusted Member
Joined: 2 years ago
 

@willyc

I’ve managed to get it installed and it seems to work (somewhat on the bootcamp side). I can’t seem to get anything to want to use the card though, even after trying to force apps to use it through graphics settings and telling them to go for performance, they still use the internal. It’s detected though which is a start. 

2019 15" MBP + Bootcamp Win 10 (19041.508)
Processor: 2.4 GHz Intel Core i9
Memory: 32 GB 2400 MHz DDR4
eGPU: Red Devil 5700 xt in a Razer Core X Chroma


ReplyQuote
Evangelos Vasilaropoulos
(@evangelos_vasilaropoulos)
Eminent Member
Joined: 3 years ago
 

Hi my system is Mac mini 2018 with razer core x and sapphire nitro plus 5700 xt. I used to have a red devil 5700 xt that was working fine with my system but I return it back for in favor of the sapphire and the triple x software. The problem that I have with the saphire is when I power on the Mac mini on windows bootcamp the razer core x fan start but the saphire not. I have to manually switch off and on the egpu enclosure in order to start the saphire. I checked the connections and all seems fine. I made some benchmarks with this card and all seems fine except some crashes on some games when is enable the triple x software. Anybody has a solution that the card doesn’t start automatically? Do you think is defect and to return it ? 

To do: Create my signature with system and expected eGPU configuration information to give context to my posts. I have no builds.

.

ReplyQuote
wimpzilla
(@wimpzilla)
Honorable Member
Joined: 5 years ago
 

If the card boots, displays a fine image, i would say it works.
As said previously, the apple and AMD Navi driver is quite new and buggy, always go with a clean install of the latest beta if possible. 

Issues like fan spin, sleep behaviors, eGPU not booting at 1st, eGPU connection problems, etc are mostly due to the new driver.
If the card in someways works in MacOS and bootcamp, i would suppose that the card is fine most of the time.

Luckily apple can speed up the driver patching process with all the precious user feedback it get here, to provide better eGPU support i hope.
So please report carefully if possible the encountered issues, strange eGPU behaviors, along performance and gaming benchmarks in both MacOS, bootcamp.
Pretty sure it will greatly help the poor end of the line devs, that are bashing the head on their desk with this buggy release.

This post was modified 2 years ago

2012 13-inch Dell Latitude E6320 + R9 270X@4Gbps-mPCIe (EXP GDC 8.4) + Win10
E=Mc²

 
2012 15" Lenovo ThinkPad T530 [2nd,4C,Q] + R9 270X @ 4Gbps-mPCIe2 (EXP GDC 8.4) + Win10 [build link]  


ReplyQuote
Evangelos Vasilaropoulos
(@evangelos_vasilaropoulos)
Eminent Member
Joined: 3 years ago
 

Thanks, the strange thing is with the previous card I tested power color red devil 5700 xt I didn’t had any of these problems.

To do: Create my signature with system and expected eGPU configuration information to give context to my posts. I have no builds.

.

ReplyQuote
mac_editor
(@mac_editor)
Famed Member Moderator
Joined: 5 years ago
 

@evangelos_vasilaropoulos

Does it work as expected without the Triple X software? Recheck power/PCIe connections/fit.

"Desultory reading is delightful, but to be beneficial, our reading must be carefully directed." — Seneca

Author: kryptonitepurge-wranglertbt-flashpurge-nvdaset-eGPU
Insights Into macOS Video Editing Performance
Launching Apps on Specific (e)GPUs on macOS

Master Threads:
2014 15-inch MacBook Pro 750M
2018 15-inch MacBook Pro

 
2019 13" MacBook Pro [8th,4C,U] + RX Vega 64 @ 32Gbps-TB3 (Mantiz Venus) + macOS 10.14.6 & Win10 [build link]  


ReplyQuote
Evangelos Vasilaropoulos
(@evangelos_vasilaropoulos)
Eminent Member
Joined: 3 years ago
 

When i boot it the triple x software is not load up. The main problem is when i boot the mac mini i have manually to turn off and on the switch on egpu to start the sapphire. Before with the red devil was turn on any time i boot the mini. I checked the connections all are fine. I am gonna try once again to remove the card and to put it again. In the default settings the hot spot of the card is getting high as 98 c and oc memory 925 with 20 power limit hot spot getting at 105 c. Is this normal?

To do: Create my signature with system and expected eGPU configuration information to give context to my posts. I have no builds.

.

ReplyQuote
 of  43